sábado, 2 de março de 2013

FÓRMULA PROCV PASSO A PASSO


PROCV



Visitem meu novo blog:

https://programacaopassoapasso.wordpress.com/



Bora aprender tudo sobre a fórmula Procv...

primeiro Procv quer dizer procurar na vertical..




Observem a tabela acima, tenho uma lista de nomes e sobrenome assim como os códigos, para a fórmula funcionar 100 % é necessário que os códigos estejam sempre em ordem crescente e se possível sempre em ordem numéria também ex: 1,2,3,4,5,6  etc.

Logo a direita temos código, nome e sobrenome, ou seja vamos digitar o código e o nome sera carregado na célula "E2" o sobrenome será carregado na célula "F2"..

mãos a obra amigos...







a fórmula é essa (só que para dar tudo certo você tem que construir uma tabela exatamente igual a minha por que se não as referencias de célula não serão corretas depois que você pegar o jeito da coisa aí você faz como quiser....

fórmula para buscar o nome (deve ser feita na célula "E2" já que é ali que queremos que apareça o nome buscado através do código.

=SE(D2="";"";PROCV(D2;A2:C8;2))

explicando:

Fórmula "se"
se a célula "D2" for igual a nada     fazer    nada       agora se não for vazia fazer(fórmula Procv)

Fórmula Procv
procurar          o valor digitado na célula "D2"        onde      aqui devemos colocar o endereço onde estão todos os nossos dados, código, nome e sobrenome         qual coluna?      no caso a coluna 1 é a que tem os códigos então só contar e colocar o numero da coluna que tem os dados desejados no caso a 2...  



depois fazemos um teste digitando um código na célula "D2" e ver se buscou corretamente...




pronto se a sua acontecer isso está completamente correto... já para o campo sobrenome é só fazer tudo de novo só que dessa vez a referencia da coluna será a de numero 3


essa deve ser colocada na célula "F2" já que lá é que vai aparecer o sobrenome...

Ex:  =SE(D2="";"";PROCV(D2;A2:C8;3))




isso aí galera qualquer coisa meu e-mail é edivan.cabral@yahoo.com.br


Edivan cabral

Um comentário:

  1. bom dia,

    nao teria esse exemplo em vba por acaso não né?

    kk

    ResponderExcluir